Payload: Untrusted redirect URL parameter exploit
CVE-2026-105846GHSA-w84c-53h3-mc2g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (payload 4.0.0-canary.27, 3.88.0; @payloadcms/next 4.0.0-canary.27, 3.88.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm payload
- Affected
- >= 3.40.0, < 3.88.0>= 4.0.0-canary.0, < 4.0.0-canary.27
- Fixed in
- 3.88.0, 4.0.0-canary.27
npm @payloadcms/next
- Affected
- >= 3.31.0, < 3.88.0>= 4.0.0-canary.0, < 4.0.0-canary.27
- Fixed in
- 3.88.0, 4.0.0-canary.27
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w84c-53h3-mc2g lists affected ranges: npm payload >=3.40.0 =4.0.0-canary.0 =3.31.0 =4.0.0-canary.0 <4.0.0-canary.27
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w84c-53h3-mc2g lists affected ranges: npm payload >=3.40.0 =4.0.0-canary.0 =3.31.0 =4.0.0-canary.0 <4.0.0-canary.27 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-105846: 0.22% estimated exploitation activity in the next 30 days; percentile 13.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Under certain conditions, an attacker can craft a redirect link that sends a guest user to an untrusted destination after authenticating. Patches Users should upgrade Payload packages to = 3.88.0 or = 4.0.0-canary.27. Workarounds Upgrading is recommended. Until then, remove user-controlled redirect values from authentication flows or restrict them to known local paths.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w84c-53h3-mc2g
- Revision 2 · amended ·
Amended from osv record GHSA-w84c-53h3-mc2g
- Revision 1 · created ·
Published from ghsa record GHSA-w84c-53h3-mc2g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-105846 Advisory: Payload: Untrusted redirect URL parameter exploit IDs: CVE-2026-105846, GHSA-w84c-53h3-mc2g Record: https://patchnext.com/advisories/cve-2026-105846 (revision 3, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: payload 4.0.0-canary.27, 3.88.0; @payloadcms/next 4.0.0-canary.27, 3.88.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm payload: affected >= 3.40.0, < 3.88.0; >= 4.0.0-canary.0, < 4.0.0-canary.27; fixed in 3.88.0, 4.0.0-canary.27 - npm @payloadcms/next: affected >= 3.31.0, < 3.88.0; >= 4.0.0-canary.0, < 4.0.0-canary.27; fixed in 3.88.0, 4.0.0-canary.27 ## Suggested inspection (read-only) - `npm ls payload --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @payloadcms/next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on payload, @payloadcms/next. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w84c-53h3-mc2g (GitHub-reviewed advisory GHSA-w84c-53h3-mc2g lists affected ranges: npm payload >=3.40.0 =4.0.0-canary.0 =3.31.0 =4.0.0-canary.0 <4.0.0-canary.27) - Verified: https://osv.dev/vulnerability/GHSA-w84c-53h3-mc2g (OSV record GHSA-w84c-53h3-mc2g lists affected ranges: npm payload >=3.40.0 =4.0.0-canary.0 =3.31.0 =4.0.0-canary.0 <4.0.0-canary.27 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…