@payloadcms/next has Stored XSS in Admin Panel
CVE-2026-34748GHSA-mmxc-95ch-2j7c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@payloadcms/next 3.78.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @payloadcms/next
- Affected
- < 3.78.0
- Fixed in
- 3.78.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mmxc-95ch-2j7c lists affected ranges: npm @payloadcms/next >=0 <3.78.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mmxc-95ch-2j7c lists affected ranges: npm @payloadcms/next >=0 <3.78.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-34748: 0.29% estimated exploitation activity in the next 30 days; percentile 21.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A stored Cross-site Scripting (XSS) vulnerability existed in the admin panel. An authenticated user with write access to a collection could save content that, when viewed by another user, would execute in their browser. Consumers are affected if ALL of these are true: - Payload version < v3.78.0 - At least one collection with versions enabled - An authenticated user has create or update access to that collection Patches This vulnerability has been patched in v3.78.0. Output encoding has been added to prevent user-supplied content from being interpreted as markup. Users should upgrade to v3.78.0 or later. Workarounds If consumers cannot upgrade immediately: - Restrict create and update access to versioned collections to trusted roles only.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mmxc-95ch-2j7c
- Revision 1 · created ·
Published from osv record GHSA-mmxc-95ch-2j7c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34748 Advisory: @payloadcms/next has Stored XSS in Admin Panel IDs: CVE-2026-34748, GHSA-mmxc-95ch-2j7c Record: https://patchnext.com/advisories/cve-2026-34748 (revision 2, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @payloadcms/next 3.78.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @payloadcms/next: affected < 3.78.0; fixed in 3.78.0 ## Suggested inspection (read-only) - `npm ls @payloadcms/next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @payloadcms/next. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mmxc-95ch-2j7c (OSV record GHSA-mmxc-95ch-2j7c lists affected ranges: npm @payloadcms/next >=0 <3.78.0 (fixed)) - Verified: https://github.com/advisories/GHSA-mmxc-95ch-2j7c (GitHub-reviewed advisory GHSA-mmxc-95ch-2j7c lists affected ranges: npm @payloadcms/next >=0 <3.78.0) Commands are suggestions: review each one before running it.
Loading voting…