Skip to content

← Public intelligence

npm package

@node-red/runtime

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratednpmAmendedPublished

    Path traversal in Node-Red

    CVE-2021-21298 · GHSA-m33v-338h-4v9f

    Affected
    • npm @node-red/runtime < 1.2.8
    Fixed in
    1.2.8· Vendor fix available
    Issue
    Impact This vulnerability allows arbitrary path traversal via the Projects API. If the Projects feature is enabled, a user with projects.read permission is able to access any file via the Projects API. Patches The issue has been patched in Node-RED 1.2.8 Workarounds The vulnerability applies only to the Projects feature which is not enabled by default in Node-RED. The primary workaround is not give untrusted users read access to the Node-RED editor. For more information If you have any questions or comments about this advisory: Email us at team@nodered.org Acknowledgements Thanks to the Tencent Woodpecker Security Team for disclosing this vulnerability.

    Recommended action: Upgrade to 1.2.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.7npmAmendedPublished

    Prototype Pollution in Node-Red

    CVE-2021-21297 · GHSA-xp9c-82x8-7f67

    Affected
    • npm @node-red/runtime < 1.2.8
    Fixed in
    1.2.8· Vendor fix available
    Issue
    Impact Node-RED 1.2.7 and earlier contains a Prototype Pollution vulnerability in the admin API. A badly formed request can modify the prototype of the default JavaScript Object with the potential to affect the default behaviour of the Node-RED runtime. Patches The vulnerability is patched in the 1.2.8 release. Workarounds A workaround is to ensure only authorised users are able to access the editor url. For more information If you have any questions or comments about this advisory: Email us at team@nodered.org Acknowledgements Thanks to the Tencent Woodpecker Security Team for disclosing this vulnerability.

    Recommended action: Upgrade to 1.2.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →