Skip to content

← Actionable
High, CVSS 7.7amended

Prototype Pollution in Node-Red

CVE-2021-21297GHSA-xp9c-82x8-7f67

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@node-red/runtime 1.2.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
EPSS
  • CVE-2021-21297: 1.40% estimated exploitation activity in the next 30 days; percentile 72.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Node-RED 1.2.7 and earlier contains a Prototype Pollution vulnerability in the admin API. A badly formed request can modify the prototype of the default JavaScript Object with the potential to affect the default behaviour of the Node-RED runtime. Patches The vulnerability is patched in the 1.2.8 release. Workarounds A workaround is to ensure only authorised users are able to access the editor url. For more information If you have any questions or comments about this advisory: Email us at team@nodered.org Acknowledgements Thanks to the Tencent Woodpecker Security Team for disclosing this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xp9c-82x8-7f67

  2. Revision 1 · created ·

    Published from osv record GHSA-xp9c-82x8-7f67

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21297

Advisory: Prototype Pollution in Node-Red
IDs: CVE-2021-21297, GHSA-xp9c-82x8-7f67
Record: https://patchnext.com/advisories/cve-2021-21297 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @node-red/runtime 1.2.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @node-red/runtime: affected < 1.2.8; fixed in 1.2.8

## Suggested inspection (read-only)
- `npm ls @node-red/runtime --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @node-red/runtime.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xp9c-82x8-7f67 (OSV record GHSA-xp9c-82x8-7f67 lists affected ranges: npm @node-red/runtime >=0 <1.2.8 (fixed))
- Verified: https://github.com/advisories/GHSA-xp9c-82x8-7f67 (GitHub-reviewed advisory GHSA-xp9c-82x8-7f67 lists affected ranges: npm @node-red/runtime >=0 <1.2.8)

Commands are suggestions: review each one before running it.

Loading voting…