Path traversal in Node-Red
CVE-2021-21298GHSA-m33v-338h-4v9f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@node-red/runtime 1.2.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.2.8
- Fixed in
- 1.2.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m33v-338h-4v9f lists affected ranges: npm @node-red/runtime >=0 <1.2.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m33v-338h-4v9f lists affected ranges: npm @node-red/runtime >=0 <1.2.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2021-21298: 1.08% estimated exploitation activity in the next 30 days; percentile 65.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This vulnerability allows arbitrary path traversal via the Projects API. If the Projects feature is enabled, a user with projects.read permission is able to access any file via the Projects API. Patches The issue has been patched in Node-RED 1.2.8 Workarounds The vulnerability applies only to the Projects feature which is not enabled by default in Node-RED. The primary workaround is not give untrusted users read access to the Node-RED editor. For more information If you have any questions or comments about this advisory: Email us at team@nodered.org Acknowledgements Thanks to the Tencent Woodpecker Security Team for disclosing this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-m33v-338h-4v9f
- Revision 1 · created ·
Published from osv record GHSA-m33v-338h-4v9f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21298 Advisory: Path traversal in Node-Red IDs: CVE-2021-21298, GHSA-m33v-338h-4v9f Record: https://patchnext.com/advisories/cve-2021-21298 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @node-red/runtime 1.2.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @node-red/runtime: affected < 1.2.8; fixed in 1.2.8 ## Suggested inspection (read-only) - `npm ls @node-red/runtime --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @node-red/runtime. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m33v-338h-4v9f (OSV record GHSA-m33v-338h-4v9f lists affected ranges: npm @node-red/runtime >=0 <1.2.8 (fixed)) - Verified: https://github.com/advisories/GHSA-m33v-338h-4v9f (GitHub-reviewed advisory GHSA-m33v-338h-4v9f lists affected ranges: npm @node-red/runtime >=0 <1.2.8) Commands are suggestions: review each one before running it.
Loading voting…