Skip to content

← Public intelligence

npm package

@cloudflare/workers-oauth-provider

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3npmAmendedPublished

    @cloudflare/workers-oauth-provider PKCE bypass via downgrade attack

    CVE-2025-4144 · GHSA-qgp8-v765-qxx9

    Affected
    • npm @cloudflare/workers-oauth-provider < 0.0.5
    Fixed in
    0.0.5· Vendor fix available
    Issue
    PKCE was implemented in the OAuth implementation in workers-oauth-provider that is part of MCP framework. However, it was found that an attacker could cause the check to be skipped. Impact PKCE is a defense-in-depth mechanism against certain kinds of attacks and was an optional extension in OAuth 2.0 which became required in the OAuth 2.1 draft. (Note that the MCP specification requires OAuth 2.1.) This bug completely bypasses PKCE protection. Patches Fixed in: https://github.com/cloudflare/workers-oauth-provider/pull/27 We patched up the vulnerabilities in the latest version, v 0.0.5 of the Workers OAuth provider (https://www.npmjs.com/package/@cloudflare/workers-oauth-provider). You'll need to update your MCP servers to use that version to resolve the vulnerability. Workarounds None

    Recommended action: Upgrade to 0.0.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.0npmAmendedPublished

    @cloudflare/workers-oauth-provider missing validation of redirect_uri on authorize endpoint

    CVE-2025-4143 · GHSA-4pc9-x2fx-p7vj

    Affected
    • npm @cloudflare/workers-oauth-provider < 0.0.5
    Fixed in
    0.0.5· Vendor fix available
    Issue
    The OAuth implementation failed to check that redirecturi was among the allowed set for the clientid. Impact Under certain circumstances (see below), if a victim had previously authorized with a server built on workers-oath-provider, and an attacker could later trick the victim into visiting a malicious web site, then attacker could potentially steal the victim's credentials to the same OAuth server and subsequently impersonate them. In order for the attack to be possible, the OAuth server's authorized callback must be designed to auto-approve authorizations that appear to come from an OAuth client that the victim has authorized previously. The authorization flow is not implemented by workers-oauth-provider; it is up to the application built on top to decide whether to implement such automatic re-authorization. However, many applications do implement such logic. Patches Fixed in: https://github.com/cloudflare/workers-oauth-provider/pull/26 We patched up the vulnerabilities in…

    Recommended action: Upgrade to 0.0.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →