Skip to content

← Actionable
Medium, CVSS 5.3amended

@cloudflare/workers-oauth-provider PKCE bypass via downgrade attack

CVE-2025-4144GHSA-qgp8-v765-qxx9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@cloudflare/workers-oauth-provider 0.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-4144: 0.58% estimated exploitation activity in the next 30 days; percentile 47.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary PKCE was implemented in the OAuth implementation in workers-oauth-provider that is part of MCP framework. However, it was found that an attacker could cause the check to be skipped. Impact PKCE is a defense-in-depth mechanism against certain kinds of attacks and was an optional extension in OAuth 2.0 which became required in the OAuth 2.1 draft. (Note that the MCP specification requires OAuth 2.1.) This bug completely bypasses PKCE protection. Patches Fixed in: https://github.com/cloudflare/workers-oauth-provider/pull/27 We patched up the vulnerabilities in the latest version, v 0.0.5 of the Workers OAuth provider (https://www.npmjs.com/package/@cloudflare/workers-oauth-provider). You'll need to update your MCP servers to use that version to resolve the vulnerability. Workarounds None

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qgp8-v765-qxx9

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-qgp8-v765-qxx9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-4144

Advisory: @cloudflare/workers-oauth-provider PKCE bypass via downgrade attack
IDs: CVE-2025-4144, GHSA-qgp8-v765-qxx9
Record: https://patchnext.com/advisories/cve-2025-4144 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @cloudflare/workers-oauth-provider 0.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @cloudflare/workers-oauth-provider: affected < 0.0.5; fixed in 0.0.5

## Suggested inspection (read-only)
- `npm ls @cloudflare/workers-oauth-provider --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @cloudflare/workers-oauth-provider.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qgp8-v765-qxx9 (OSV record GHSA-qgp8-v765-qxx9 lists affected ranges: npm @cloudflare/workers-oauth-provider >=0 <0.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-qgp8-v765-qxx9 (GitHub-reviewed advisory GHSA-qgp8-v765-qxx9 lists affected ranges: npm @cloudflare/workers-oauth-provider >=0 <0.0.5)

Commands are suggestions: review each one before running it.

Loading voting…