Skip to content

← Actionable
Medium, CVSS 6.0amended

@cloudflare/workers-oauth-provider missing validation of redirect_uri on authorize endpoint

CVE-2025-4143GHSA-4pc9-x2fx-p7vj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@cloudflare/workers-oauth-provider 0.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N · score source
EPSS
  • CVE-2025-4143: 0.33% estimated exploitation activity in the next 30 days; percentile 26.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The OAuth implementation failed to check that redirecturi was among the allowed set for the clientid. Impact Under certain circumstances (see below), if a victim had previously authorized with a server built on workers-oath-provider, and an attacker could later trick the victim into visiting a malicious web site, then attacker could potentially steal the victim's credentials to the same OAuth server and subsequently impersonate them. In order for the attack to be possible, the OAuth server's authorized callback must be designed to auto-approve authorizations that appear to come from an OAuth client that the victim has authorized previously. The authorization flow is not implemented by workers-oauth-provider; it is up to the application built on top to decide whether to implement such automatic re-authorization. However, many applications do implement such logic. Patches Fixed in: https://github.com/cloudflare/workers-oauth-provider/pull/26 We patched up the vulnerabilities in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4pc9-x2fx-p7vj

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4pc9-x2fx-p7vj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-4143

Advisory: @cloudflare/workers-oauth-provider missing validation of redirect_uri on authorize endpoint
IDs: CVE-2025-4143, GHSA-4pc9-x2fx-p7vj
Record: https://patchnext.com/advisories/cve-2025-4143 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @cloudflare/workers-oauth-provider 0.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @cloudflare/workers-oauth-provider: affected < 0.0.5; fixed in 0.0.5

## Suggested inspection (read-only)
- `npm ls @cloudflare/workers-oauth-provider --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @cloudflare/workers-oauth-provider.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4pc9-x2fx-p7vj (OSV record GHSA-4pc9-x2fx-p7vj lists affected ranges: npm @cloudflare/workers-oauth-provider >=0 <0.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-4pc9-x2fx-p7vj (GitHub-reviewed advisory GHSA-4pc9-x2fx-p7vj lists affected ranges: npm @cloudflare/workers-oauth-provider >=0 <0.0.5)

Commands are suggestions: review each one before running it.

Loading voting…