Skip to content

← Public intelligence

npm package

@clerk/shared

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.6npmAmendedPublished

    Clerk has an authorization bypass when combining organization, billing, or reverification checks

    CVE-2026-42349 · GHSA-w24r-5266-9c3c

    Affected
    • npm @clerk/shared >= 3.0.0, <= 3.47.4; >= 4.0.0, <= 4.8.2
    Fixed in
    4.8.33.47.5· Vendor fix available
    Issue
    has(), auth.protect(), and related authorization predicates in @clerk/shared, @clerk/nextjs, @clerk/backend, and other framework SDKs can return true for certain combined authorization checks when the result should be false, allowing a gated action to proceed for a user who does not satisfy the full set of requested conditions. Sessions are not compromised and no existing user can be impersonated. The bypass is limited to the authorization decision returned by the predicate. clerkMiddleware continues to authenticate requests correctly, auth() reflects the real authentication state, and token verification is unaffected. Who is affected All apps that combine more than one authorization dimension in a single has() or auth.protect() call should upgrade to the patched versions. Patches are drop-in with no API changes. The information below describes the scope of the bypass and helps developers understand whether their apps are potentially affected, but is not a reason to delay the…

    Recommended action: Upgrade to 4.8.3 or 3.47.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.1npmAmendedPublished

    Official Clerk JavaScript SDKs: Middleware-based route protection bypass

    CVE-2026-41248 · GHSA-vqx2-fgx2-5wq9

    Affected
    • npm @clerk/shared >= 2.20.17, < 2.22.1; >= 3.0.0-canary.v20250225091530, < 3.47.4; >= 4.0.0, < 4.8.1
    Fixed in
    2.22.13.47.44.8.1· Vendor fix available
    Issue
    createRouteMatcher in @clerk/nextjs, @clerk/nuxt, and @clerk/astro can be bypassed by certain crafted requests, allowing them to skip middleware gating and reach downstream handlers. Sessions are not compromised and no existing user can be impersonated - the bypass only affects the middleware-level gating decision. Who is affected All apps using createRouteMatcher should upgrade to the patched versions. Patches are drop-in with no API changes. The information below describes the scope of the bypass and helps you understand whether you are potentially affected, but is not a reason to delay the upgrade. Apps relying only on middleware gating via createRouteMatcher are affected, because a crafted request can skip middleware checks and reach downstream handlers (API routes, server components, etc.). This middleware pattern permits the bypass: That said, the bypass is limited to the middleware-level route-matching gate. clerkMiddleware still authenticates the request and auth()…

    Recommended action: Upgrade to 4.8.1, 3.47.4 or 2.22.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →