Official Clerk JavaScript SDKs: Middleware-based route protection bypass
CVE-2026-41248GHSA-vqx2-fgx2-5wq9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@clerk/nuxt 2.2.2, 1.13.28; @clerk/astro 3.0.15, 2.17.10, 1.5.7; @clerk/nextjs 7.2.1, 6.39.2, 5.7.6; @clerk/shared 4.8.1, 3.47.4, 2.22.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @clerk/nuxt
- Affected
- >= 1.1.0, < 1.13.28>= 2.0.0, < 2.2.2
- Fixed in
- 2.2.2, 1.13.28
npm @clerk/astro
- Affected
- >= 0.0.1, < 1.5.7>= 2.0.0-snapshot.v20241206174604, <= 2.17.9>= 3.0.0, < 3.0.15
- Fixed in
- 2.17.10, 3.0.15, 1.5.7
npm @clerk/nextjs
- Affected
- >= 5.0.0, < 5.7.6>= 6.0.0-snapshot.vb87a27f, < 6.39.2>= 7.0.0, < 7.2.1
- Fixed in
- 6.39.2, 5.7.6, 7.2.1
npm @clerk/shared
- Affected
- >= 2.20.17, < 2.22.1>= 3.0.0-canary.v20250225091530, < 3.47.4>= 4.0.0, < 4.8.1
- Fixed in
- 2.22.1, 3.47.4, 4.8.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vqx2-fgx2-5wq9 lists affected ranges: npm @clerk/nextjs >=5.0.0 =6.0.0-snapshot.vb87a27f =7.0.0 =1.1.0 =2.0.0 =0.0.1 =2.0.0-snapshot.v20241206174604 =3.0.0 =2.20.17 =3.0.0-canary.v20250225091530 =4.0.0 <4.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vqx2-fgx2-5wq9 lists affected ranges: npm @clerk/nextjs >=5.0.0 =6.0.0-snapshot.vb87a27f =7.0.0 =1.1.0 =2.0.0 =0.0.1 =2.0.0-snapshot.v20241206174604 =3.0.0 =2.20.17 =3.0.0-canary.v20250225091530 =4.0.0 <4.8.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-41248: 0.32% estimated exploitation activity in the next 30 days; percentile 25.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary createRouteMatcher in @clerk/nextjs, @clerk/nuxt, and @clerk/astro can be bypassed by certain crafted requests, allowing them to skip middleware gating and reach downstream handlers. Sessions are not compromised and no existing user can be impersonated - the bypass only affects the middleware-level gating decision. Who is affected All apps using createRouteMatcher should upgrade to the patched versions. Patches are drop-in with no API changes. The information below describes the scope of the bypass and helps you understand whether you are potentially affected, but is not a reason to delay the upgrade. Apps relying only on middleware gating via createRouteMatcher are affected, because a crafted request can skip middleware checks and reach downstream handlers (API routes, server components, etc.). This middleware pattern permits the bypass: That said, the bypass is limited to the middleware-level route-matching gate. clerkMiddleware still authenticates the request and auth()…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vqx2-fgx2-5wq9
- Revision 2 · amended ·
Amended from osv record GHSA-vqx2-fgx2-5wq9
- Revision 1 · created ·
Published from ghsa record GHSA-vqx2-fgx2-5wq9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41248 Advisory: Official Clerk JavaScript SDKs: Middleware-based route protection bypass IDs: CVE-2026-41248, GHSA-vqx2-fgx2-5wq9 Record: https://patchnext.com/advisories/cve-2026-41248 (revision 3, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @clerk/nuxt 2.2.2, 1.13.28; @clerk/astro 3.0.15, 2.17.10, 1.5.7; @clerk/nextjs 7.2.1, 6.39.2, 5.7.6; @clerk/shared 4.8.1, 3.47.4, 2.22.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @clerk/nuxt: affected >= 1.1.0, < 1.13.28; >= 2.0.0, < 2.2.2; fixed in 2.2.2, 1.13.28 - npm @clerk/astro: affected >= 0.0.1, < 1.5.7; >= 2.0.0-snapshot.v20241206174604, <= 2.17.9; >= 3.0.0, < 3.0.15; fixed in 2.17.10, 3.0.15, 1.5.7 - npm @clerk/nextjs: affected >= 5.0.0, < 5.7.6; >= 6.0.0-snapshot.vb87a27f, < 6.39.2; >= 7.0.0, < 7.2.1; fixed in 6.39.2, 5.7.6, 7.2.1 - npm @clerk/shared: affected >= 2.20.17, < 2.22.1; >= 3.0.0-canary.v20250225091530, < 3.47.4; >= 4.0.0, < 4.8.1; fixed in 2.22.1, 3.47.4, 4.8.1 ## Suggested inspection (read-only) - `npm ls @clerk/nuxt --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @clerk/astro --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @clerk/nextjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @clerk/shared --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @clerk/nuxt, @clerk/astro, @clerk/nextjs, @clerk/shared. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vqx2-fgx2-5wq9 (GitHub-reviewed advisory GHSA-vqx2-fgx2-5wq9 lists affected ranges: npm @clerk/nextjs >=5.0.0 =6.0.0-snapshot.vb87a27f =7.0.0 =1.1.0 =2.0.0 =0.0.1 =2.0.0-snapshot.v20241206174604 =3.0.0 =2.20.17 =3.0.0-canary.v20250225091530 =4.0.0 <4.8.1) - Verified: https://osv.dev/vulnerability/GHSA-vqx2-fgx2-5wq9 (OSV record GHSA-vqx2-fgx2-5wq9 lists affected ranges: npm @clerk/nextjs >=5.0.0 =6.0.0-snapshot.vb87a27f =7.0.0 =1.1.0 =2.0.0 =0.0.1 =2.0.0-snapshot.v20241206174604 =3.0.0 =2.20.17 =3.0.0-canary.v20250225091530 =4.0.0 <4.8.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…