Malicious Package in eslint-scope
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (eslint-scope 3.7.3; eslint-config-eslint 6.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm eslint-scope
- Affected
- >= 3.7.2, <= 3.7.2
- Fixed in
- 3.7.3
- Affected
- >= 5.0.2, <= 5.0.2
- Fixed in
- 6.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hxxf-q3w9-4xgw lists affected ranges: npm eslint-scope >=3.7.2 =5.0.2 <6.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hxxf-q3w9-4xgw lists affected ranges: npm eslint-scope >=3.7.2 =5.0.2 <=5.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Version 3.7.2 of eslint-scope was published without authorization and was found to contain malicious code. This code would read the users .npmrc file and send any found authentication tokens to 2 remote servers. Recommendation The best course of action if you found this package installed in your environment is to revoke all your npm tokens. You can find instructions on how to do that here. https://docs.npmjs.com/getting-started/workingwithtokens#how-to-revoke-tokens
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hxxf-q3w9-4xgw
- Revision 1 · created ·
Published from osv record GHSA-hxxf-q3w9-4xgw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-hxxf-q3w9-4xgw Advisory: Malicious Package in eslint-scope IDs: GHSA-hxxf-q3w9-4xgw Record: https://patchnext.com/advisories/ghsa-hxxf-q3w9-4xgw (revision 2, source checked 26 Oct 2026, 12:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: eslint-scope 3.7.3; eslint-config-eslint 6.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm eslint-scope: affected >= 3.7.2, <= 3.7.2; fixed in 3.7.3 - npm eslint-config-eslint: affected >= 5.0.2, <= 5.0.2; fixed in 6.0.0 ## Suggested inspection (read-only) - `npm ls eslint-scope --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls eslint-config-eslint --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on eslint-scope, eslint-config-eslint. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hxxf-q3w9-4xgw (OSV record GHSA-hxxf-q3w9-4xgw lists affected ranges: npm eslint-scope >=3.7.2 =5.0.2 <6.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-hxxf-q3w9-4xgw (GitHub-reviewed advisory GHSA-hxxf-q3w9-4xgw lists affected ranges: npm eslint-scope >=3.7.2 =5.0.2 <=5.0.2) Commands are suggestions: review each one before running it.
Loading voting…