Critical, CVSS 9.1npmAmendedPublished
Malicious Package in eslint-scope
GHSA-hxxf-q3w9-4xgw
- Affected
- npm eslint-config-eslint >= 5.0.2, <= 5.0.2
- Fixed in
- 6.0.0· Vendor fix available
- Issue
- Version 3.7.2 of eslint-scope was published without authorization and was found to contain malicious code. This code would read the users .npmrc file and send any found authentication tokens to 2 remote servers. Recommendation The best course of action if you found this package installed in your environment is to revoke all your npm tokens. You can find instructions on how to do that here. https://docs.npmjs.com/getting-started/workingwithtokens#how-to-revoke-tokens
Recommended action: Upgrade to 6.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.