Skip to content

← Public intelligence

npm package

eslint-scope

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.1npmAmendedPublished

    Malicious Package in eslint-scope

    GHSA-hxxf-q3w9-4xgw

    Affected
    • npm eslint-scope >= 3.7.2, <= 3.7.2
    Fixed in
    3.7.3· Vendor fix available
    Issue
    Version 3.7.2 of eslint-scope was published without authorization and was found to contain malicious code. This code would read the users .npmrc file and send any found authentication tokens to 2 remote servers. Recommendation The best course of action if you found this package installed in your environment is to revoke all your npm tokens. You can find instructions on how to do that here. https://docs.npmjs.com/getting-started/workingwithtokens#how-to-revoke-tokens

    Recommended action: Upgrade to 3.7.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →