Webrecorder packages are vulnerable to XSS through 404 error handling logic
CVE-2025-58765GHSA-w765-jm6w-4hhj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@webrecorder/wabac 2.23.11; @webrecorder/archivewebpage 0.15.4; replaywebpage 2.3.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.23.11
- Fixed in
- 2.23.11
npm @webrecorder/archivewebpage
- Affected
- < 0.15.4
- Fixed in
- 0.15.4
npm replaywebpage
- Affected
- < 2.3.17
- Fixed in
- 2.3.17
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w765-jm6w-4hhj lists affected ranges: npm @webrecorder/wabac >=0 =0 =0 <0.15.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w765-jm6w-4hhj lists affected ranges: npm @webrecorder/wabac >=0 =0 =0 <0.15.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- EPSS
- CVE-2025-58765: 0.25% estimated exploitation activity in the next 30 days; percentile 16.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Reflected Cross-Site Scripting (XSS) vulnerability exists in the 404 error handling logic of wabac.js v2.23.10 and below. The parameter requestURL (derived from the original request target) is directly embedded into an inline <script block without sanitization or escaping. This allows an attacker to craft a malicious URL that executes arbitrary JavaScript in the victim’s browser. The scope may be limited by CORS policies, depending on the situation in which wabac.js is used. Patches The vulnerability is fixed in wabac.js v2.23.11.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w765-jm6w-4hhj
- Revision 1 · created ·
Published from osv record GHSA-w765-jm6w-4hhj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-58765 Advisory: Webrecorder packages are vulnerable to XSS through 404 error handling logic IDs: CVE-2025-58765, GHSA-w765-jm6w-4hhj Record: https://patchnext.com/advisories/cve-2025-58765 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @webrecorder/wabac 2.23.11; @webrecorder/archivewebpage 0.15.4; replaywebpage 2.3.17. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @webrecorder/wabac: affected < 2.23.11; fixed in 2.23.11 - npm @webrecorder/archivewebpage: affected < 0.15.4; fixed in 0.15.4 - npm replaywebpage: affected < 2.3.17; fixed in 2.3.17 ## Suggested inspection (read-only) - `npm ls @webrecorder/wabac --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @webrecorder/archivewebpage --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls replaywebpage --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @webrecorder/wabac, @webrecorder/archivewebpage, replaywebpage. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w765-jm6w-4hhj (OSV record GHSA-w765-jm6w-4hhj lists affected ranges: npm @webrecorder/wabac >=0 =0 =0 <0.15.4 (fixed)) - Verified: https://github.com/advisories/GHSA-w765-jm6w-4hhj (GitHub-reviewed advisory GHSA-w765-jm6w-4hhj lists affected ranges: npm @webrecorder/wabac >=0 =0 =0 <0.15.4) Commands are suggestions: review each one before running it.
Loading voting…