High, CVSS 7.1npmAmendedPublished
Webrecorder packages are vulnerable to XSS through 404 error handling logic
CVE-2025-58765 · GHSA-w765-jm6w-4hhj
- Affected
- npm @webrecorder/wabac < 2.23.11
- Fixed in
- 2.23.11· Vendor fix available
- Issue
- A Reflected Cross-Site Scripting (XSS) vulnerability exists in the 404 error handling logic of wabac.js v2.23.10 and below. The parameter requestURL (derived from the original request target) is directly embedded into an inline <script block without sanitization or escaping. This allows an attacker to craft a malicious URL that executes arbitrary JavaScript in the victim’s browser. The scope may be limited by CORS policies, depending on the situation in which wabac.js is used. Patches The vulnerability is fixed in wabac.js v2.23.11.
Recommended action: Upgrade to 2.23.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.