Skip to content

← Public intelligence

npm package

@webrecorder/archivewebpage

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.1npmAmendedPublished

    Webrecorder packages are vulnerable to XSS through 404 error handling logic

    CVE-2025-58765 · GHSA-w765-jm6w-4hhj

    Affected
    • npm @webrecorder/archivewebpage < 0.15.4
    Fixed in
    0.15.4· Vendor fix available
    Issue
    A Reflected Cross-Site Scripting (XSS) vulnerability exists in the 404 error handling logic of wabac.js v2.23.10 and below. The parameter requestURL (derived from the original request target) is directly embedded into an inline <script block without sanitization or escaping. This allows an attacker to craft a malicious URL that executes arbitrary JavaScript in the victim’s browser. The scope may be limited by CORS policies, depending on the situation in which wabac.js is used. Patches The vulnerability is fixed in wabac.js v2.23.11.

    Recommended action: Upgrade to 0.15.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →