Skip to content

← Actionable
High, CVSS 8.6

XWiki's required right warnings for macros are incomplete

CVE-2025-49582GHSA-c32m-27pj-4xcj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-security-requiredrights-default 17.0.0, 16.10.3, 16.4.7; org.xwiki.platform:xwiki-platform-rendering-macro-context 17.0.0, 16.10.3, 16.4.7; org.xwiki.platform:xwiki-platform-rendering-macro-cache 17.0.0, 16.10.3, 16.4.7; org.xwiki.platform:xwiki-platform-rendering-xwiki 17.0.0, 16.10.3, 16.4.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-c32m-27pj-4xcj lists affected ranges: Maven org.xwiki.platform:xwiki-platform-rendering-xwiki >=15.9-rc-1 =16.5.0-rc-1 =17.0.0-rc-1 =15.9-rc-1 =16.5.0-rc-1 =17.0.0-rc-1 =15.9-rc-1 =16.5.0-rc-1 =17.0.0-rc-1 <17.0.0; Maven…

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-49582: 0.91% estimated exploitation activity in the next 30 days; percentile 60.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When editing content that contains "dangerous" macros like malicious script macros that were authored by a user with fewer rights, XWiki warns about the execution of these macros since XWiki 15.9RC1. These required rights analyzers that trigger these warnings are incomplete, allowing an attacker to hide malicious content. For most macros, the existing analyzers don't consider non-lowercase parameters. Further, most macro parameters that can contain XWiki syntax like titles of information boxes weren't analyzed at all. Similarly, the "source" parameters of the content and context macro weren't anylzed even though they could contain arbitrary XWiki syntax. In the worst case, this could allow a malicious to add malicious script macros including Groovy or Python macros to a page that are then executed after another user with programming righs edits the page, thus allowing remote code execution. Patches The required rights analyzers have been made more robust and extended to cover…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c32m-27pj-4xcj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-49582

Advisory: XWiki's required right warnings for macros are incomplete
IDs: CVE-2025-49582, GHSA-c32m-27pj-4xcj
Record: https://patchnext.com/advisories/cve-2025-49582 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-security-requiredrights-default 17.0.0, 16.10.3, 16.4.7; org.xwiki.platform:xwiki-platform-rendering-macro-context 17.0.0, 16.10.3, 16.4.7; org.xwiki.platform:xwiki-platform-rendering-macro-cache 17.0.0, 16.10.3, 16.4.7; org.xwiki.platform:xwiki-platform-rendering-xwiki 17.0.0, 16.10.3, 16.4.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-security-requiredrights-default: affected >= 15.9-rc-1, < 16.4.7; >= 16.5.0-rc-1, < 16.10.3; >= 17.0.0-rc-1, < 17.0.0; fixed in 17.0.0, 16.10.3, 16.4.7
- Maven org.xwiki.platform:xwiki-platform-rendering-macro-context: affected >= 15.9-rc-1, < 16.4.7; >= 16.5.0-rc-1, < 16.10.3; >= 17.0.0-rc-1, < 17.0.0; fixed in 17.0.0, 16.10.3, 16.4.7
- Maven org.xwiki.platform:xwiki-platform-rendering-macro-cache: affected >= 15.9-rc-1, < 16.4.7; >= 16.5.0-rc-1, < 16.10.3; >= 17.0.0-rc-1, < 17.0.0; fixed in 17.0.0, 16.10.3, 16.4.7
- Maven org.xwiki.platform:xwiki-platform-rendering-xwiki: affected >= 15.9-rc-1, < 16.4.7; >= 16.5.0-rc-1, < 16.10.3; >= 17.0.0-rc-1, < 17.0.0; fixed in 17.0.0, 16.10.3, 16.4.7

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-security-requiredrights-default: check the installed version with your package manager.
- Maven org.xwiki.platform:xwiki-platform-rendering-macro-context: check the installed version with your package manager.
- Maven org.xwiki.platform:xwiki-platform-rendering-macro-cache: check the installed version with your package manager.
- Maven org.xwiki.platform:xwiki-platform-rendering-xwiki: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-security-requiredrights-default, org.xwiki.platform:xwiki-platform-rendering-macro-context, org.xwiki.platform:xwiki-platform-rendering-macro-cache, org.xwiki.platform:xwiki-platform-rendering-xwiki.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c32m-27pj-4xcj (GitHub-reviewed advisory GHSA-c32m-27pj-4xcj lists affected ranges: Maven org.xwiki.platform:xwiki-platform-rendering-xwiki >=15.9-rc-1 =16.5.0-rc-1 =17.0.0-rc-1 =15.9-rc-1 =16.5.0-rc-1 =17.0.0-rc-1 =15.9-rc-1 =16.5.0-rc-1 =17.0.0-rc-1 <17.0.0; Maven…)

Commands are suggestions: review each one before running it.

Loading voting…