Skip to content

← Public intelligence

Maven package

org.xwiki.platform:xwiki-platform-rendering-xwiki

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.6MavenPublished

    XWiki's required right warnings for macros are incomplete

    CVE-2025-49582 · GHSA-c32m-27pj-4xcj

    Affected
    • Maven org.xwiki.platform:xwiki-platform-rendering-xwiki >= 15.9-rc-1, < 16.4.7; >= 16.5.0-rc-1, < 16.10.3; >= 17.0.0-rc-1, < 17.0.0
    Fixed in
    17.0.016.10.316.4.7· Vendor fix available
    Issue
    Impact When editing content that contains "dangerous" macros like malicious script macros that were authored by a user with fewer rights, XWiki warns about the execution of these macros since XWiki 15.9RC1. These required rights analyzers that trigger these warnings are incomplete, allowing an attacker to hide malicious content. For most macros, the existing analyzers don't consider non-lowercase parameters. Further, most macro parameters that can contain XWiki syntax like titles of information boxes weren't analyzed at all. Similarly, the "source" parameters of the content and context macro weren't anylzed even though they could contain arbitrary XWiki syntax. In the worst case, this could allow a malicious to add malicious script macros including Groovy or Python macros to a page that are then executed after another user with programming righs edits the page, thus allowing remote code execution. Patches The required rights analyzers have been made more robust and extended to cover…

    Recommended action: Upgrade to 17.0.0, 16.10.3 or 16.4.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.9MavenPublished

    org.xwiki.platform:xwiki-platform-rendering-xwiki vulnerable to stored cross-site scripting via HTML and raw macro

    CVE-2023-29205 · GHSA-vxf7-mx22-jr24

    Affected
    • Maven org.xwiki.platform:xwiki-platform-rendering-xwiki < 14.8-rc-1
    Fixed in
    14.8-rc-1· Vendor fix available
    Issue
    Impact The HTML macro does not systematically perform a proper neutralization of script-related html tags. As a result, any user able to use the html macro in XWiki, is able to introduce an XSS attack. This can be particularly dangerous since in a standard wiki, any user is able to use the html macro directly in their own user profile page. Patches The problem has been patched in XWiki 14.8RC1. The patch involve that the HTML macro are systematically cleaned up whenever the user does not have script right. Workarounds There's no workaround for this issue. For more information If you have any questions or comments about this advisory: Open an issue in Jira Email us at security ML

    Recommended action: Upgrade to 14.8-rc-1 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →