Skip to content

← Public intelligence

Maven package

org.xwiki.platform:xwiki-platform-rendering-macro-context

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.6MavenPublished

    XWiki's required right warnings for macros are incomplete

    CVE-2025-49582 · GHSA-c32m-27pj-4xcj

    Affected
    • Maven org.xwiki.platform:xwiki-platform-rendering-macro-context >= 15.9-rc-1, < 16.4.7; >= 16.5.0-rc-1, < 16.10.3; >= 17.0.0-rc-1, < 17.0.0
    Fixed in
    17.0.016.10.316.4.7· Vendor fix available
    Issue
    Impact When editing content that contains "dangerous" macros like malicious script macros that were authored by a user with fewer rights, XWiki warns about the execution of these macros since XWiki 15.9RC1. These required rights analyzers that trigger these warnings are incomplete, allowing an attacker to hide malicious content. For most macros, the existing analyzers don't consider non-lowercase parameters. Further, most macro parameters that can contain XWiki syntax like titles of information boxes weren't analyzed at all. Similarly, the "source" parameters of the content and context macro weren't anylzed even though they could contain arbitrary XWiki syntax. In the worst case, this could allow a malicious to add malicious script macros including Groovy or Python macros to a page that are then executed after another user with programming righs edits the page, thus allowing remote code execution. Patches The required rights analyzers have been made more robust and extended to cover…

    Recommended action: Upgrade to 17.0.0, 16.10.3 or 16.4.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.4MavenPublished

    xwiki contains Incorrect Authorization

    CVE-2023-26056 · GHSA-859x-p6jp-rc2w

    Affected
    • Maven org.xwiki.platform:xwiki-platform-rendering-macro-context >= 3.0-milestone-1, < 13.10.10; >= 14.0-rc-1, < 14.4.5; >= 14.5, < 14.8-rc-1
    Fixed in
    14.4.514.8-rc-113.10.10· Vendor fix available
    Issue
    Impact It's possible to execute a script with the right of another user (provided the target user does not have programming right). For example, the following: written by a user not having script right (for example in the user's profile) should produce an error (the user is not allowed to write scripts). However, because of the vulnerability, if the author of the document "xwiki:XWiki.userwithscriptright" has script right (but not programming right) the script will be executed with as if it was written by the target user. Patches The problem has been patched in XWiki 14.8RC1, 14.4.5 and 13.10.10. Workarounds There's no workaround for this issue. References https://jira.xwiki.org/browse/XWIKI-19856 For more information If you have any questions or comments about this advisory: Open an issue in JIRA Email us at security ML

    Recommended action: Upgrade to 14.8-rc-1 (pre-release), 14.4.5 or 13.10.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →