Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite
CVE-2025-27794GHSA-hg9j-64wp-m9px
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flarum/framework 1.8.10; flarum/core 1.8.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist flarum/framework
- Affected
- < 1.8.10
- Fixed in
- 1.8.10
Packagist flarum/core
- Affected
- < 1.8.10
- Fixed in
- 1.8.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hg9j-64wp-m9px lists affected ranges: Packagist flarum/core >=0 =0 <1.8.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2025-27794: 0.50% estimated exploitation activity in the next 30 days; percentile 42.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A session hijacking vulnerability exists when an attacker-controlled authoritative subdomain under a parent domain (e.g., subdomain.host.com) sets cookies scoped to the parent domain (.host.com). This allows session token replacement for applications hosted on sibling subdomains (e.g., community.host.com) if session tokens aren't rotated post-authentication. Key Constraints: - Attacker must control any subdomain under the parent domain (e.g., evil.host.com or x.y.host.com). - Parent domain must not be on the Public Suffix List. Due to non-existent session token rotation after authenticating we can theoretically reproduce the vulnerability by using browser dev tools, but due to the browser's security measures this does not seem to be exploitable as described. --- Proof of Concept (Deno) Attack Flow 1. Attacker Setup: Hosts server at evil.host.com. 2. Harvest Session Token: Attacker visits community.host.com to get a session token for himself to replace the victim's token with…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hg9j-64wp-m9px
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-27794 Advisory: Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite IDs: CVE-2025-27794, GHSA-hg9j-64wp-m9px Record: https://patchnext.com/advisories/cve-2025-27794 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flarum/framework 1.8.10; flarum/core 1.8.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist flarum/framework: affected < 1.8.10; fixed in 1.8.10 - Packagist flarum/core: affected < 1.8.10; fixed in 1.8.10 ## Suggested inspection (read-only) - Packagist flarum/framework: check the installed version with your package manager. - Packagist flarum/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flarum/framework, flarum/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hg9j-64wp-m9px (GitHub-reviewed advisory GHSA-hg9j-64wp-m9px lists affected ranges: Packagist flarum/core >=0 =0 <1.8.10) Commands are suggestions: review each one before running it.
Loading voting…