Skip to content

← Actionable
Medium, CVSS 6.5

Flarum's logout Route allows open redirects

CVE-2024-21641GHSA-733r-8xcp-w9mr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flarum/framework 1.8.5; flarum/core 1.8.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2024-21641: 1.07% estimated exploitation activity in the next 30 days; percentile 64.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Flarum /logout route includes a redirect parameter that allows any third party to redirect users from a (trusted) domain of the Flarum installation to redirect to any link. Sample: example.com/logout?return=https://google.com. For logged-in users, the logout must be confirmed. Guests are immediately redirected. This could be used by spammers to redirect to a web address using a trusted domain of a running Flarum installation. Some ecosystem extensions modifying the logout route have already been affected. Sample: https://discuss.flarum.org/d/22229-premium-wordpress-integration/526 Patches The vulnerability has been fixed and published as flarum/core v1.8.5. All communities running Flarum should upgrade as soon as possible to v1.8.5 using: composer update --prefer-dist --no-dev -a -W You can then confirm you run the latest version using: composer show flarum/core Workarounds Some extensions modifying the logout route can remedy this issue if their implementation is safe. In…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-733r-8xcp-w9mr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-21641

Advisory: Flarum's logout Route allows open redirects
IDs: CVE-2024-21641, GHSA-733r-8xcp-w9mr
Record: https://patchnext.com/advisories/cve-2024-21641 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flarum/framework 1.8.5; flarum/core 1.8.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist flarum/framework: affected < 1.8.5; fixed in 1.8.5
- Packagist flarum/core: affected < 1.8.5; fixed in 1.8.5

## Suggested inspection (read-only)
- Packagist flarum/framework: check the installed version with your package manager.
- Packagist flarum/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flarum/framework, flarum/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-733r-8xcp-w9mr (GitHub-reviewed advisory GHSA-733r-8xcp-w9mr lists affected ranges: Packagist flarum/core >=0 =0 <1.8.5)

Commands are suggestions: review each one before running it.

Loading voting…