Skip to content

← Actionable
High, CVSS 7.1

Flarum vulnerable to LFI and Blind SSRF via Avatar upload

CVE-2023-40033GHSA-67c6-q4j4-hccg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flarum/framework 1.8.0; flarum/core 1.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2023-40033: 0.50% estimated exploitation activity in the next 30 days; percentile 43.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Flarum forum software is affected by a vulnerability that allows an attacker to conduct a Blind SSRF attack or disclose any file on the server, even with a basic user account on any Flarum forum. By uploading a file containing a URL and spoofing the MIME type, an attacker can manipulate the application to execute unintended actions. The vulnerability is due to the behavior of the intervention/image package, which attempts to interpret the supplied file contents as a URL, which then fetches its contents. This allows an attacker to exploit the vulnerability to perform SSRF attacks, disclose local file contents, or conduct a blind oracle attack. Patches This has been patched in Flarum v1.8. Workarounds As a temporary workaround for the SSRF aspect of the vulnerability, one can disable PHP's allowurlfopen which will prevent the fetching of external files via URLs. Credits Adam Kues - Assetnote

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-67c6-q4j4-hccg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-40033

Advisory: Flarum vulnerable to LFI and Blind SSRF via Avatar upload
IDs: CVE-2023-40033, GHSA-67c6-q4j4-hccg
Record: https://patchnext.com/advisories/cve-2023-40033 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flarum/framework 1.8.0; flarum/core 1.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist flarum/framework: affected < 1.8.0; fixed in 1.8.0
- Packagist flarum/core: affected < 1.8.0; fixed in 1.8.0

## Suggested inspection (read-only)
- Packagist flarum/framework: check the installed version with your package manager.
- Packagist flarum/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flarum/framework, flarum/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-67c6-q4j4-hccg (GitHub-reviewed advisory GHSA-67c6-q4j4-hccg lists affected ranges: Packagist flarum/core >=0 =0 <1.8.0)

Commands are suggestions: review each one before running it.

Loading voting…