Cross-site Scripting in OpenCRX
CVE-2021-25959GHSA-rwh9-8xx8-4wfm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opencrx:opencrx-client 5.2.0; org.opencrx:opencrx-gradle 5.2.0; org.opencrx:opencrx-core 5.2.0; org.opencrx:opencrx-core-models 5.2.0; org.opencrx:opencrx-core-config 5.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.opencrx:opencrx-client
- Affected
- >= 4.0.0, < 5.2.0
- Fixed in
- 5.2.0
Maven org.opencrx:opencrx-gradle
- Affected
- >= 4.0.0, < 5.2.0
- Fixed in
- 5.2.0
Maven org.opencrx:opencrx-core
- Affected
- >= 4.0.0, < 5.2.0
- Fixed in
- 5.2.0
Maven org.opencrx:opencrx-core-models
- Affected
- >= 4.0.0, < 5.2.0
- Fixed in
- 5.2.0
Maven org.opencrx:opencrx-core-config
- Affected
- >= 4.0.0, < 5.2.0
- Fixed in
- 5.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rwh9-8xx8-4wfm lists affected ranges: Maven org.opencrx:opencrx-core >=4.0.0 =4.0.0 =4.0.0 =4.0.0 =4.0.0 <5.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-25959: 0.86% estimated exploitation activity in the next 30 days; percentile 58.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the password reset functionality. This allows execution of external javascript files on any user of the openCRX instance.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rwh9-8xx8-4wfm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-25959 Advisory: Cross-site Scripting in OpenCRX IDs: CVE-2021-25959, GHSA-rwh9-8xx8-4wfm Record: https://patchnext.com/advisories/cve-2021-25959 (revision 1, source checked 26 Oct 2026, 16:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.opencrx:opencrx-client 5.2.0; org.opencrx:opencrx-gradle 5.2.0; org.opencrx:opencrx-core 5.2.0; org.opencrx:opencrx-core-models 5.2.0; org.opencrx:opencrx-core-config 5.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.opencrx:opencrx-client: affected >= 4.0.0, < 5.2.0; fixed in 5.2.0 - Maven org.opencrx:opencrx-gradle: affected >= 4.0.0, < 5.2.0; fixed in 5.2.0 - Maven org.opencrx:opencrx-core: affected >= 4.0.0, < 5.2.0; fixed in 5.2.0 - Maven org.opencrx:opencrx-core-models: affected >= 4.0.0, < 5.2.0; fixed in 5.2.0 - Maven org.opencrx:opencrx-core-config: affected >= 4.0.0, < 5.2.0; fixed in 5.2.0 ## Suggested inspection (read-only) - Maven org.opencrx:opencrx-client: check the installed version with your package manager. - Maven org.opencrx:opencrx-gradle: check the installed version with your package manager. - Maven org.opencrx:opencrx-core: check the installed version with your package manager. - Maven org.opencrx:opencrx-core-models: check the installed version with your package manager. - Maven org.opencrx:opencrx-core-config: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.opencrx:opencrx-client, org.opencrx:opencrx-gradle, org.opencrx:opencrx-core, org.opencrx:opencrx-core-models, org.opencrx:opencrx-core-config. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rwh9-8xx8-4wfm (GitHub-reviewed advisory GHSA-rwh9-8xx8-4wfm lists affected ranges: Maven org.opencrx:opencrx-core >=4.0.0 =4.0.0 =4.0.0 =4.0.0 =4.0.0 <5.2.0) Commands are suggestions: review each one before running it.
Loading voting…