Skip to content

← Public intelligence

Maven package

org.opencrx:opencrx-client

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8MavenPublished

    OpenCRX allows a remote attacker to execute arbitrary code via a crafted request

    CVE-2023-46502 · GHSA-q74f-rf27-8hxc

    Affected
    • Maven org.opencrx:opencrx-client < 5.3.0
    Fixed in
    5.3.0· Vendor fix available
    Issue
    An issue in OpenCRX v.5.2.2 allows a remote attacker to execute arbitrary code via a crafted request.

    Recommended action: Upgrade to 5.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.3MavenPublished

    OpenCRX vulnerable to password enumeration via error messages in password reset

    CVE-2022-40084 · GHSA-j5v3-363p-g843

    Affected
    • Maven org.opencrx:opencrx-client < 5.2.2
    Fixed in
    5.2.2· Vendor fix available
    Issue
    OpenCRX before v5.2.2 was discovered to be vulnerable to password enumeration due to the difference in error messages received during a password reset which could enable an attacker to determine if a username, email or ID is valid.

    Recommended action: Upgrade to 5.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.1MavenPublished

    Cross-site Scripting in OpenCRX

    CVE-2021-25959 · GHSA-rwh9-8xx8-4wfm

    Affected
    • Maven org.opencrx:opencrx-client >= 4.0.0, < 5.2.0
    Fixed in
    5.2.0· Vendor fix available
    Issue
    In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the password reset functionality. This allows execution of external javascript files on any user of the openCRX instance.

    Recommended action: Upgrade to 5.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →