Medium, CVSS 6.1MavenPublished
Cross-site Scripting in OpenCRX
CVE-2021-25959 · GHSA-rwh9-8xx8-4wfm
- Affected
- Maven org.opencrx:opencrx-core >= 4.0.0, < 5.2.0
- Fixed in
- 5.2.0· Vendor fix available
- Issue
- In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the password reset functionality. This allows execution of external javascript files on any user of the openCRX instance.
Recommended action: Upgrade to 5.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.