Denial of service vulnerability exists when System.IO.Pipelines improperly handles requests
CVE-2018-8409GHSA-j378-6mmw-hqfr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (system.io.pipelines 4.5.1; microsoft.aspnetcore.all 2.1.4; microsoft.aspnetcore.app 2.1.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet system.io.pipelines
- Affected
- >= 4.5.0, <= 4.5.0
- Fixed in
- 4.5.1
NuGet microsoft.aspnetcore.all
- Affected
- >= 2.1.0, <= 2.1.3
- Fixed in
- 2.1.4
NuGet microsoft.aspnetcore.app
- Affected
- >= 2.1.0, <= 2.1.3
- Fixed in
- 2.1.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j378-6mmw-hqfr lists affected ranges: NuGet microsoft.aspnetcore.all >=2.1.0 =2.1.0 =4.5.0 <=4.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2018-8409: 6.56% estimated exploitation activity in the next 30 days; percentile 93.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A denial of service vulnerability exists when System.IO.Pipelines improperly handles requests, aka "System.IO.Pipelines Denial of Service." This affects .NET Core 2.1, System.IO.Pipelines, ASP.NET Core 2.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j378-6mmw-hqfr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-8409 Advisory: Denial of service vulnerability exists when System.IO.Pipelines improperly handles requests IDs: CVE-2018-8409, GHSA-j378-6mmw-hqfr Record: https://patchnext.com/advisories/cve-2018-8409 (revision 1, source checked 26 Oct 2026, 16:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: system.io.pipelines 4.5.1; microsoft.aspnetcore.all 2.1.4; microsoft.aspnetcore.app 2.1.4. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet system.io.pipelines: affected >= 4.5.0, <= 4.5.0; fixed in 4.5.1 - NuGet microsoft.aspnetcore.all: affected >= 2.1.0, <= 2.1.3; fixed in 2.1.4 - NuGet microsoft.aspnetcore.app: affected >= 2.1.0, <= 2.1.3; fixed in 2.1.4 ## Suggested inspection (read-only) - NuGet system.io.pipelines: check the installed version with your package manager. - NuGet microsoft.aspnetcore.all: check the installed version with your package manager. - NuGet microsoft.aspnetcore.app: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on system.io.pipelines, microsoft.aspnetcore.all, microsoft.aspnetcore.app. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j378-6mmw-hqfr (GitHub-reviewed advisory GHSA-j378-6mmw-hqfr lists affected ranges: NuGet microsoft.aspnetcore.all >=2.1.0 =2.1.0 =4.5.0 <=4.5.0) Commands are suggestions: review each one before running it.
Loading voting…