Skip to content

← Public intelligence

NuGet package

microsoft.aspnetcore.all

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

10 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5NuGetPublished

    ASP.NET Core Denial of Service Vulnerability

    CVE-2020-1597 · GHSA-f8qx-mjcq-wfgx

    Affected
    • NuGet microsoft.aspnetcore.all >= 2.1.0, < 2.1.21
    Fixed in
    2.1.21· Vendor fix available
    Issue
    A denial of service vulnerability exists when ASP.NET Core improperly handles web requests, aka ASP.NET Core Denial of Service Vulnerability.

    Recommended action: Upgrade to 2.1.21 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedNuGetPublished

    Remote code execution in ASP.NET Core

    CVE-2020-0603 · GHSA-655q-9gvg-q4cm

    Affected
    • NuGet microsoft.aspnetcore.all >= 2.1.0, < 2.1.15
    Fixed in
    2.1.15· Vendor fix available
    Issue
    A remote code execution vulnerability exists in ASP.NET Core software when the software fails to handle objects in memory.An attacker who successfully exploited the vulnerability could run arbitrary code in the context of the current user, aka 'ASP.NET Core Remote Code Execution Vulnerability'.

    Recommended action: Upgrade to 2.1.15 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedNuGetPublished

    Denial of service in ASP.NET Core

    CVE-2020-0602 · GHSA-23cv-jh4v-vffm

    Affected
    • NuGet microsoft.aspnetcore.all >= 2.1.0, < 2.1.15
    Fixed in
    2.1.15· Vendor fix available
    Issue
    A denial of service vulnerability exists when ASP.NET Core improperly handles web requests, aka 'ASP.NET Core Denial of Service Vulnerability'.

    Recommended action: Upgrade to 2.1.15 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 6.1NuGetPublished

    Open redirect in ASP.NET Core

    CVE-2019-1075 · GHSA-prrf-397v-83xh

    Affected
    • NuGet microsoft.aspnetcore.all >= 2.2.0, < 2.2.6; >= 2.1.0, < 2.1.12
    Fixed in
    2.1.122.2.6· Vendor fix available
    Issue
    A spoofing vulnerability exists in ASP.NET Core that could lead to an open redirect, aka 'ASP.NET Core Spoofing Vulnerability'.

    Recommended action: Upgrade to 2.2.6 or 2.1.12 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 8.8NuGetPublished

    Open redirect in ASP.NET Core

    CVE-2017-11879 · GHSA-3wcj-rg8q-9cqv

    Affected
    • NuGet microsoft.aspnetcore.all >= 2.0.0, < 2.0.3
    Fixed in
    2.0.3· Vendor fix available
    Issue
    ASP.NET Core 2.0 allows an attacker to steal log-in session information such as cookies or authentication tokens via a specially crafted URL aka "ASP.NET Core Elevation Of Privilege Vulnerability".

    Recommended action: Upgrade to 2.0.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. High, CVSS 7.5NuGetPublished

    Denial of service in ASP.NET Core

    CVE-2019-0564 · GHSA-6px8-22w5-w334

    Affected
    • NuGet microsoft.aspnetcore.all >= 2.2.0, <= 2.2.0; >= 2.1.0, < 2.1.7
    Fixed in
    2.1.72.2.1· Vendor fix available
    Issue
    A denial of service vulnerability exists when ASP.NET Core improperly handles web requests, aka "ASP.NET Core Denial of Service Vulnerability." This affects ASP.NET Core 2.1. This CVE ID is unique from CVE-2019-0548.

    Recommended action: Upgrade to 2.2.1 or 2.1.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. UnratedNuGetPublished

    Moderate severity vulnerability that affects Microsoft.AspNetCore.All, Microsoft.AspNetCore.App, and Microsoft.AspNetCore.Server.Kestrel.Core

    GHSA-cgpw-2gph-2r9g

    Affected
    • NuGet microsoft.aspnetcore.all >= 2.0.0, < 2.0.9; >= 2.1.0, < 2.1.2
    Fixed in
    2.0.92.1.2· Vendor fix available
    Issue
    Microsoft is aware of a denial of service vulnerability in ASP.NET Core when a malformed request is terminated. An attacker who successfully exploited this vulnerability could cause a denial of service attack. The update addresses the vulnerability by correcting how ASP.NET Core handles such requests.

    Recommended action: Upgrade to 2.1.2 or 2.0.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  8. UnratedNuGetPublished

    Moderate severity vulnerability that affects Microsoft.AspNetCore.All, Microsoft.AspNetCore.Server.Kestrel.Core, Microsoft.AspNetCore.Server.Kestrel.Transport.Abstractions, and…

    GHSA-3m2r-q8x3-xmf7

    Affected
    • NuGet microsoft.aspnetcore.all >= 2.0.0, < 2.0.8
    Fixed in
    2.0.8· Vendor fix available
    Issue
    Microsoft made an internal discovery of a security vulnerability in version 2.x of ASP.NET Core where a specially crafted request can cause excess resource consumption in Kestrel.

    Recommended action: Upgrade to 2.0.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  9. High, CVSS 7.5NuGetPublished

    Denial of service in ASP.NET Core

    CVE-2018-8269 · GHSA-mv2r-q4g5-j8q5

    Affected
    • NuGet microsoft.aspnetcore.all >= 2.1.0, < 2.1.13; >= 2.2.0, < 2.2.7
    Fixed in
    2.2.72.1.13· Vendor fix available
    Issue
    A denial of service vulnerability exists when OData Library improperly handles web requests, aka "OData Denial of Service Vulnerability." This affects Microsoft.Data.OData.

    Recommended action: Upgrade to 2.2.7 or 2.1.13 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  10. High, CVSS 7.5NuGetPublished

    Denial of service vulnerability exists when System.IO.Pipelines improperly handles requests

    CVE-2018-8409 · GHSA-j378-6mmw-hqfr

    Affected
    • NuGet microsoft.aspnetcore.all >= 2.1.0, <= 2.1.3
    Fixed in
    2.1.4· Vendor fix available
    Issue
    A denial of service vulnerability exists when System.IO.Pipelines improperly handles requests, aka "System.IO.Pipelines Denial of Service." This affects .NET Core 2.1, System.IO.Pipelines, ASP.NET Core 2.1.

    Recommended action: Upgrade to 2.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →