High, CVSS 7.5NuGetPublished
Denial of service vulnerability exists when System.IO.Pipelines improperly handles requests
CVE-2018-8409 · GHSA-j378-6mmw-hqfr
- Affected
- NuGet system.io.pipelines >= 4.5.0, <= 4.5.0
- Fixed in
- 4.5.1· Vendor fix available
- Issue
- A denial of service vulnerability exists when System.IO.Pipelines improperly handles requests, aka "System.IO.Pipelines Denial of Service." This affects .NET Core 2.1, System.IO.Pipelines, ASP.NET Core 2.1.
Recommended action: Upgrade to 4.5.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.