Skip to content

← Actionable
High, CVSS 8.8

gollum and gollum-lib allow remote authenticated users to execute arbitrary code

CVE-2014-9489GHSA-q97v-764g-r2rp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gollum 3.1.1; gollum-lib 4.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems gollum

    Affected
    < 3.1.1
    Fixed in
    3.1.1
  • RubyGems gollum-lib

    Affected
    < 4.0.1
    Fixed in
    4.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2014-9489: 2.94% estimated exploitation activity in the next 30 days; percentile 87.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The gollum-gritadapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem dependency in gollum-lib before 4.0.1 when the string master is in any of the wiki documents, allows remote authenticated users to execute arbitrary code via the -O or --open-files-in-pager flags.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q97v-764g-r2rp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-9489

Advisory: gollum and gollum-lib allow remote authenticated users to execute arbitrary code
IDs: CVE-2014-9489, GHSA-q97v-764g-r2rp
Record: https://patchnext.com/advisories/cve-2014-9489 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gollum 3.1.1; gollum-lib 4.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems gollum: affected < 3.1.1; fixed in 3.1.1
- RubyGems gollum-lib: affected < 4.0.1; fixed in 4.0.1

## Suggested inspection (read-only)
- RubyGems gollum: check the installed version with your package manager.
- RubyGems gollum-lib: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gollum, gollum-lib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q97v-764g-r2rp (GitHub-reviewed advisory GHSA-q97v-764g-r2rp lists affected ranges: RubyGems gollum >=0 =0 <4.0.1)

Commands are suggestions: review each one before running it.

Loading voting…