High, CVSS 8.8RubyGemsPublished
gollum and gollum-lib allow remote authenticated users to execute arbitrary code
CVE-2014-9489 · GHSA-q97v-764g-r2rp
- Affected
- RubyGems gollum-lib < 4.0.1
- Fixed in
- 4.0.1· Vendor fix available
- Issue
- The gollum-gritadapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem dependency in gollum-lib before 4.0.1 when the string master is in any of the wiki documents, allows remote authenticated users to execute arbitrary code via the -O or --open-files-in-pager flags.
Recommended action: Upgrade to 4.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.