Skip to content

← Public intelligence

RubyGems package

gollum

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1RubyGemsPublished

    Gollum Cross-site Scripting vulnerability via filename parameter to New Page dialog

    CVE-2020-35305 · GHSA-fj2w-qmjp-3rjm

    Affected
    • RubyGems gollum >= 5.0, < 5.1.2
    Fixed in
    5.1.2· Vendor fix available
    Issue
    Cross site scripting (XSS) in gollum 5.0 to 5.1.2 via the filename parameter to the 'New Page' dialog.

    Recommended action: Upgrade to 5.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedRubyGemsPublished

    Gollum Exposure of Sensitive Information

    CVE-2015-7314 · GHSA-m2q3-53fq-7h66

    Affected
    • RubyGems gollum < 4.0.1
    Fixed in
    4.0.1· Vendor fix available
    Issue
    The Precious module in gollum before 4.0.1 allows remote attackers to read arbitrary files by leveraging the lack of a certain temporary-file check.

    Recommended action: Upgrade to 4.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.8RubyGemsPublished

    gollum and gollum-lib allow remote authenticated users to execute arbitrary code

    CVE-2014-9489 · GHSA-q97v-764g-r2rp

    Affected
    • RubyGems gollum < 3.1.1
    Fixed in
    3.1.1· Vendor fix available
    Issue
    The gollum-gritadapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem dependency in gollum-lib before 4.0.1 when the string master is in any of the wiki documents, allows remote authenticated users to execute arbitrary code via the -O or --open-files-in-pager flags.

    Recommended action: Upgrade to 3.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →