Low, CVSS 2.1PyPIAmendedPublished
Wooey has an Incorrect Privilege Assignment issue
CVE-2026-7142 · GHSA-w65c-cmxj-qrhm
- Affected
- PyPI wooey < 0.13.3rc1
- Fixed in
- 0.13.3rc1· Vendor fix available
- Issue
- A vulnerability was determined in Wooey up to 0.13.2. The impacted element is the function addorupdatescript of the file wooey/api/scripts.py of the component API Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 0.13.3rc1 and 0.14.0 is sufficient to resolve this issue. This patch is called f7846fc0c323da8325422cab32623491757f1b88. The affected component should be upgraded.
Recommended action: Upgrade to 0.13.3rc1 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.