Wooey has an Incorrect Privilege Assignment issue
CVE-2026-7142GHSA-w65c-cmxj-qrhm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wooey 0.13.3rc1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI wooey
- Affected
- < 0.13.3rc1
- Fixed in
- 0.13.3rc1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w65c-cmxj-qrhm lists affected ranges: PyPI wooey >=0 <0.13.3rc1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w65c-cmxj-qrhm lists affected ranges: PyPI wooey >=0 <0.13.3rc1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-7142: 0.21% estimated exploitation activity in the next 30 days; percentile 11.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was determined in Wooey up to 0.13.2. The impacted element is the function addorupdatescript of the file wooey/api/scripts.py of the component API Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 0.13.3rc1 and 0.14.0 is sufficient to resolve this issue. This patch is called f7846fc0c323da8325422cab32623491757f1b88. The affected component should be upgraded.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w65c-cmxj-qrhm
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-w65c-cmxj-qrhm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-7142 Advisory: Wooey has an Incorrect Privilege Assignment issue IDs: CVE-2026-7142, GHSA-w65c-cmxj-qrhm Record: https://patchnext.com/advisories/cve-2026-7142 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wooey 0.13.3rc1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI wooey: affected < 0.13.3rc1; fixed in 0.13.3rc1 ## Suggested inspection (read-only) - `python -m pip show wooey`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wooey. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w65c-cmxj-qrhm (OSV record GHSA-w65c-cmxj-qrhm lists affected ranges: PyPI wooey >=0 <0.13.3rc1 (fixed)) - Verified: https://github.com/advisories/GHSA-w65c-cmxj-qrhm (GitHub-reviewed advisory GHSA-w65c-cmxj-qrhm lists affected ranges: PyPI wooey >=0 <0.13.3rc1) Commands are suggestions: review each one before running it.
Loading voting…