Critical, CVSS 9.3PyPIAmendedPublished
WMAgent arbitrary code execution via a crafted dbs-client package
CVE-2022-34558 · GHSA-4vq7-8699-4xgc
- Affected
- PyPI wmagent >= 1.3.3rc1, <= 1.3.3rc2
- Fixed in
- 2.0.4· Vendor fix available
- Issue
- WMAgent v1.3.3rc2 and 1.3.3rc1, reqmgr2 1.4.1rc5 and 1.4.0rc2, reqmon 1.4.1rc5, and global-workqueue 1.4.1rc5 allows attackers to execute arbitrary code via a crafted dbs-client package.
Recommended action: Upgrade to 2.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.