Skip to content

← Actionable
Critical, CVSS 9.3amended

WMAgent arbitrary code execution via a crafted dbs-client package

CVE-2022-34558GHSA-4vq7-8699-4xgc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wmagent 2.0.4; global-workqueue 2.0.4; reqmgr2 2.0.4; reqmon 2.0.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI wmagent

    Affected
    >= 1.3.3rc1, <= 1.3.3rc2
    Fixed in
    2.0.4
  • PyPI global-workqueue

    Affected
    >= 1.4.1rc5, <= 1.4.1rc5
    Fixed in
    2.0.4
  • PyPI reqmgr2

    Affected
    >= 1.4.0rc2, <= 1.4.1rc5
    Fixed in
    2.0.4
  • PyPI reqmon

    Affected
    >= 1.4.1rc5, <= 1.4.1rc5
    Fixed in
    2.0.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-34558: 1.30% estimated exploitation activity in the next 30 days; percentile 70.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

WMAgent v1.3.3rc2 and 1.3.3rc1, reqmgr2 1.4.1rc5 and 1.4.0rc2, reqmon 1.4.1rc5, and global-workqueue 1.4.1rc5 allows attackers to execute arbitrary code via a crafted dbs-client package.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4vq7-8699-4xgc

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4vq7-8699-4xgc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-34558

Advisory: WMAgent arbitrary code execution via a crafted dbs-client package
IDs: CVE-2022-34558, GHSA-4vq7-8699-4xgc
Record: https://patchnext.com/advisories/cve-2022-34558 (revision 3, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wmagent 2.0.4; global-workqueue 2.0.4; reqmgr2 2.0.4; reqmon 2.0.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI wmagent: affected >= 1.3.3rc1, <= 1.3.3rc2; fixed in 2.0.4
- PyPI global-workqueue: affected >= 1.4.1rc5, <= 1.4.1rc5; fixed in 2.0.4
- PyPI reqmgr2: affected >= 1.4.0rc2, <= 1.4.1rc5; fixed in 2.0.4
- PyPI reqmon: affected >= 1.4.1rc5, <= 1.4.1rc5; fixed in 2.0.4

## Suggested inspection (read-only)
- `python -m pip show wmagent`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show global-workqueue`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show reqmgr2`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show reqmon`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wmagent, global-workqueue, reqmgr2, reqmon.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4vq7-8699-4xgc (OSV record GHSA-4vq7-8699-4xgc lists affected ranges: PyPI wmagent >=1.3.3rc1 =1.4.0rc2 =1.4.1rc5 =1.4.1rc5 <2.0.4 (fixed))
- Verified: https://github.com/advisories/GHSA-4vq7-8699-4xgc (GitHub-reviewed advisory GHSA-4vq7-8699-4xgc lists affected ranges: PyPI wmagent >=1.3.3rc1 =1.4.0rc2 =1.4.1rc5 =1.4.1rc5 <=1.4.1rc5)

Commands are suggestions: review each one before running it.

Loading voting…