Skip to content

← Public intelligence

PyPI package

wheel

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.1PyPIAmendedPublished

    Wheel Affected by Arbitrary File Permission Modification via Path Traversal in wheel unpack

    CVE-2026-24049 · GHSA-8rrh-rw8j-w5fx

    Affected
    • PyPI wheel >= 0.40.0, <= 0.46.1
    Fixed in
    0.46.2· Vendor fix available
    Issue
    - Vulnerability Type: Path Traversal (CWE-22) leading to Arbitrary File Permission Modification. - Root Cause Component: wheel.cli.unpack.unpack function. - Affected Packages: 1. wheel (Upstream source) 2. setuptools (Downstream, vendors wheel) - Severity: High (Allows modifying system file permissions). Details The vulnerability exists in how the unpack function handles file permissions after extraction. The code blindly trusts the filename from the archive header for the chmod operation, even though the extraction process itself might have sanitized the path. PoC I have confirmed this exploit works against the unpack function imported from setuptools.vendor.wheel.cli.unpack. Prerequisites: pip install setuptools Step 1: Generate the Malicious Wheel (genpoc.py) This script creates a wheel that passes internal hash validation but contains a directory traversal payload in the file list. Step 2: Run the Exploit (exploit.py) result: <img width="806" height="838" alt="image"…

    Recommended action: Upgrade to 0.46.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.5PyPIAmendedPublished

    pypa/wheel vulnerable to Regular Expression denial of service (ReDoS)

    CVE-2022-40898 · GHSA-qwmp-2cf2-g9g6

    Affected
    • PyPI wheel < 0.38.1
    Fixed in
    0.38.1· Vendor fix available
    Issue
    Python Packaging Authority (PyPA) Wheel is a reference implementation of the Python wheel packaging standard. Wheel 0.37.1 and earlier are vulnerable to a Regular Expression denial of service via attacker controlled input to the wheel cli. The vulnerable regex is used to verify the validity of Wheel file names. This has been patched in version 0.38.1.

    Recommended action: Upgrade to 0.38.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →