Skip to content

← Actionable
High, CVSS 7.1amended

Wheel Affected by Arbitrary File Permission Modification via Path Traversal in wheel unpack

CVE-2026-24049GHSA-8rrh-rw8j-w5fx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wheel 0.46.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI wheel

    Affected
    >= 0.40.0, <= 0.46.1
    Fixed in
    0.46.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-24049: 0.35% estimated exploitation activity in the next 30 days; percentile 28.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary - Vulnerability Type: Path Traversal (CWE-22) leading to Arbitrary File Permission Modification. - Root Cause Component: wheel.cli.unpack.unpack function. - Affected Packages: 1. wheel (Upstream source) 2. setuptools (Downstream, vendors wheel) - Severity: High (Allows modifying system file permissions). Details The vulnerability exists in how the unpack function handles file permissions after extraction. The code blindly trusts the filename from the archive header for the chmod operation, even though the extraction process itself might have sanitized the path. PoC I have confirmed this exploit works against the unpack function imported from setuptools.vendor.wheel.cli.unpack. Prerequisites: pip install setuptools Step 1: Generate the Malicious Wheel (genpoc.py) This script creates a wheel that passes internal hash validation but contains a directory traversal payload in the file list. Step 2: Run the Exploit (exploit.py) result: <img width="806" height="838" alt="image"…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8rrh-rw8j-w5fx

  2. Revision 1 · created ·

    Published from osv record GHSA-8rrh-rw8j-w5fx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24049

Advisory: Wheel Affected by Arbitrary File Permission Modification via Path Traversal in wheel unpack
IDs: CVE-2026-24049, GHSA-8rrh-rw8j-w5fx
Record: https://patchnext.com/advisories/cve-2026-24049 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wheel 0.46.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI wheel: affected >= 0.40.0, <= 0.46.1; fixed in 0.46.2

## Suggested inspection (read-only)
- `python -m pip show wheel`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wheel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8rrh-rw8j-w5fx (OSV record GHSA-8rrh-rw8j-w5fx lists affected ranges: PyPI wheel >=0.40.0 <0.46.2 (fixed))
- Verified: https://github.com/advisories/GHSA-8rrh-rw8j-w5fx (GitHub-reviewed advisory GHSA-8rrh-rw8j-w5fx lists affected ranges: PyPI wheel >=0.40.0 <=0.46.1)

Commands are suggestions: review each one before running it.

Loading voting…