Skip to content

← Public intelligence

PyPI package

vitrage

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.1PyPIAmendedPublished

    OpenStack Vitrage: Unauthorized Access to the Host can Lead to Eval Injection

    CVE-2026-28370 · GHSA-8xwf-cr4r-856r

    Affected
    • PyPI vitrage >= 15.0.0.0rc1, < 15.0.1; >= 14.0.0.0rc1, < 14.0.1; >= 13.0.0.0rc1, < 13.0.1; < 12.0.1
    Fixed in
    14.0.115.0.113.0.112.0.1· Vendor fix available
    Issue
    In the query parser in OpenStack Vitrage before 12.0.1, 13.0.0, 14.0.0, and 15.0.0, a user allowed to access the Vitrage API may trigger code execution on the Vitrage service host as the user the Vitrage service runs under. This may result in unauthorized access to the host and further compromise of the Vitrage service. All deployments exposing the Vitrage API are affected. This occurs in createqueryfunction in vitrage/graph/query.py.

    Recommended action: Upgrade to 15.0.1, 14.0.1, 13.0.1 or 12.0.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →