Skip to content

← Actionable
Critical, CVSS 9.1amended

OpenStack Vitrage: Unauthorized Access to the Host can Lead to Eval Injection

CVE-2026-28370GHSA-8xwf-cr4r-856r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vitrage 15.0.1, 14.0.1, 13.0.1, 12.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vitrage

    Affected
    >= 15.0.0.0rc1, < 15.0.1>= 14.0.0.0rc1, < 14.0.1>= 13.0.0.0rc1, < 13.0.1< 12.0.1
    Fixed in
    14.0.1, 15.0.1, 13.0.1, 12.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-28370: 0.85% estimated exploitation activity in the next 30 days; percentile 58.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In the query parser in OpenStack Vitrage before 12.0.1, 13.0.0, 14.0.0, and 15.0.0, a user allowed to access the Vitrage API may trigger code execution on the Vitrage service host as the user the Vitrage service runs under. This may result in unauthorized access to the host and further compromise of the Vitrage service. All deployments exposing the Vitrage API are affected. This occurs in createqueryfunction in vitrage/graph/query.py.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8xwf-cr4r-856r

  2. Revision 2 · amended ·

    Amended from osv record GHSA-8xwf-cr4r-856r

  3. Revision 1 · created ·

    Published from ghsa record GHSA-8xwf-cr4r-856r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28370

Advisory: OpenStack Vitrage: Unauthorized Access to the Host can Lead to Eval Injection
IDs: CVE-2026-28370, GHSA-8xwf-cr4r-856r
Record: https://patchnext.com/advisories/cve-2026-28370 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vitrage 15.0.1, 14.0.1, 13.0.1, 12.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vitrage: affected >= 15.0.0.0rc1, < 15.0.1; >= 14.0.0.0rc1, < 14.0.1; >= 13.0.0.0rc1, < 13.0.1; < 12.0.1; fixed in 14.0.1, 15.0.1, 13.0.1, 12.0.1

## Suggested inspection (read-only)
- `python -m pip show vitrage`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vitrage.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8xwf-cr4r-856r (GitHub-reviewed advisory GHSA-8xwf-cr4r-856r lists affected ranges: PyPI vitrage >=15.0.0.0rc1 =14.0.0.0rc1 =13.0.0.0rc1 =0 <12.0.1)
- Verified: https://osv.dev/vulnerability/GHSA-8xwf-cr4r-856r (OSV record GHSA-8xwf-cr4r-856r lists affected ranges: PyPI vitrage >=15.0.0.0rc1 =14.0.0.0rc1 =13.0.0.0rc1 =0 <12.0.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…