Skip to content

← Public intelligence

PyPI package

uwsgi

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5PyPIAmendedPublished

    Apache HTTP Server via mod_proxy_uwsgi HTTP response smuggling

    CVE-2023-27522 · GHSA-vcph-37mh-fqrh

    Affected
    • PyPI uwsgi < 2.0.22
    Fixed in
    2.0.22· Vendor fix available
    Issue
    HTTP Response Smuggling vulnerability in Apache HTTP Server via modproxyuwsgi. This issue affects Apache HTTP Server from 2.4.30 through 2.4.55 and the uWSGI PyPI package prior to version 2.0.22. Special characters in the origin response header can truncate/split the response forwarded to the client.

    Recommended action: Upgrade to 2.0.22 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.7PyPIAmendedPublished

    uWSGI Directory Traversal vulnerability

    CVE-2018-7490 · GHSA-h2vm-c85r-5vh5

    Affected
    • PyPI uwsgi < 2.0.17
    Fixed in
    2.0.17· Vendor fix available
    Issue
    uWSGI before 2.0.17 mishandles a DOCUMENTROOT check during use of the --php-docroot option, allowing directory traversal.

    Recommended action: Upgrade to 2.0.17 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →