Skip to content

← Actionable
High, CVSS 7.5amended

Apache HTTP Server via mod_proxy_uwsgi HTTP response smuggling

CVE-2023-27522GHSA-vcph-37mh-fqrh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (uwsgi 2.0.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI uwsgi

    Affected
    < 2.0.22
    Fixed in
    2.0.22

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2023-27522: 2.13% estimated exploitation activity in the next 30 days; percentile 82.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

HTTP Response Smuggling vulnerability in Apache HTTP Server via modproxyuwsgi. This issue affects Apache HTTP Server from 2.4.30 through 2.4.55 and the uWSGI PyPI package prior to version 2.0.22. Special characters in the origin response header can truncate/split the response forwarded to the client.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vcph-37mh-fqrh

  2. Revision 1 · created ·

    Published from osv record GHSA-vcph-37mh-fqrh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-27522

Advisory: Apache HTTP Server via mod_proxy_uwsgi HTTP response smuggling
IDs: CVE-2023-27522, GHSA-vcph-37mh-fqrh
Record: https://patchnext.com/advisories/cve-2023-27522 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: uwsgi 2.0.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI uwsgi: affected < 2.0.22; fixed in 2.0.22

## Suggested inspection (read-only)
- `python -m pip show uwsgi`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on uwsgi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vcph-37mh-fqrh (OSV record GHSA-vcph-37mh-fqrh lists affected ranges: PyPI uwsgi >=0 <2.0.22 (fixed))
- Verified: https://github.com/advisories/GHSA-vcph-37mh-fqrh (GitHub-reviewed advisory GHSA-vcph-37mh-fqrh lists affected ranges: PyPI uwsgi >=0 <2.0.22)

Commands are suggestions: review each one before running it.

Loading voting…