Skip to content

← Public intelligence

PyPI package

upsonic

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8PyPIAmendedPublished

    Upsonic: remote code execution vulnerability in its MCP server/task creation functionality

    CVE-2026-30625 · GHSA-cw73-5f7h-m4gv

    Affected
    • PyPI upsonic < 0.72.0
    Fixed in
    0.72.0· Vendor fix available
    Issue
    Upsonic 0.71.6 contains a remote code execution vulnerability in its MCP server/task creation functionality. The application allows users to define MCP tasks with arbitrary command and args values. Although an allowlist exists, certain allowed commands (npm, npx) accept argument flags that enable execution of arbitrary OS commands. Maliciously crafted MCP tasks may lead to remote code execution with the privileges of the Upsonic process. In version 0.72.0 Upsonic added a warning about using Stdio servers being able to execute commands directly on the machine.

    Recommended action: Upgrade to 0.72.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →
  2. Low, CVSS 2.0PyPIAmendedPublished

    Upsonic has vulnerability in Pickle Handler component that can lead to deserialization

    CVE-2025-6279 · GHSA-rpfv-46xj-5984

    Affected
    • PyPI upsonic < 0.56.0
    Fixed in
    0.56.0· Vendor fix available
    Issue
    A vulnerability, which was classified as critical, has been found in Upsonic up to 0.55.6. This issue affects the function cloudpickle.loads of the file /tools/addtool of the component Pickle Handler. The manipulation leads to deserialization. The exploit has been disclosed to the public and may be used.

    Recommended action: Upgrade to 0.56.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Low, CVSS 2.0PyPIAmendedPublished

    Upsonic is vulnerable to Path Traversal attack through its os.path.join function

    CVE-2025-6278 · GHSA-8jf4-fcjr-68c2

    Affected
    • PyPI upsonic < 0.56.0
    Fixed in
    0.56.0· Vendor fix available
    Issue
    A vulnerability classified as critical was found in Upsonic up to 0.55.6. This vulnerability affects the function os.path.join of the file markdown/server.py. The manipulation of the argument file.filename leads to path traversal. The exploit has been disclosed to the public and may be used.

    Recommended action: Upgrade to 0.56.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →