Upsonic: remote code execution vulnerability in its MCP server/task creation functionality
CVE-2026-30625GHSA-cw73-5f7h-m4gv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (upsonic 0.72.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI upsonic
- Affected
- < 0.72.0
- Fixed in
- 0.72.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cw73-5f7h-m4gv lists affected ranges: PyPI upsonic >=0 <0.72.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cw73-5f7h-m4gv lists affected ranges: PyPI upsonic >=0 <0.72.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-30625: 0.97% estimated exploitation activity in the next 30 days; percentile 62.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Upsonic 0.71.6 contains a remote code execution vulnerability in its MCP server/task creation functionality. The application allows users to define MCP tasks with arbitrary command and args values. Although an allowlist exists, certain allowed commands (npm, npx) accept argument flags that enable execution of arbitrary OS commands. Maliciously crafted MCP tasks may lead to remote code execution with the privileges of the Upsonic process. In version 0.72.0 Upsonic added a warning about using Stdio servers being able to execute commands directly on the machine.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-cw73-5f7h-m4gv
- Revision 2 · amended ·
Amended from osv record GHSA-cw73-5f7h-m4gv
- Revision 1 · created ·
Published from ghsa record GHSA-cw73-5f7h-m4gv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-30625 Advisory: Upsonic: remote code execution vulnerability in its MCP server/task creation functionality IDs: CVE-2026-30625, GHSA-cw73-5f7h-m4gv Record: https://patchnext.com/advisories/cve-2026-30625 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: upsonic 0.72.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI upsonic: affected < 0.72.0; fixed in 0.72.0 ## Suggested inspection (read-only) - `python -m pip show upsonic`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on upsonic. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cw73-5f7h-m4gv (GitHub-reviewed advisory GHSA-cw73-5f7h-m4gv lists affected ranges: PyPI upsonic >=0 <0.72.0) - Verified: https://osv.dev/vulnerability/GHSA-cw73-5f7h-m4gv (OSV record GHSA-cw73-5f7h-m4gv lists affected ranges: PyPI upsonic >=0 <0.72.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…