Skip to content

← Public intelligence

PyPI package

ubi-reader

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.8PyPIAmendedPublished

    Path traversal in ubi-reader

    CVE-2023-0591 · GHSA-vp2x-3mc3-3cj4

    Affected
    • PyPI ubi-reader < 0.8.5
    Fixed in
    0.8.5· Vendor fix available
    Issue
    ubireaderextractfiles is vulnerable to path traversal when run against specifically crafted UBIFS files, allowing the attacker to overwrite files outside of the extraction directory (provided the process has write access to that file or directory). This is due to the fact that a node name (dentnode.name) is considered trusted and joined to the extraction directory path during processing, then the node content is written to that joined path. By crafting a malicious UBIFS file with node names holding path traversal payloads (e.g. ../../tmp/outside.txt), it's possible to force ubireader to write outside of the extraction directory. This issue affects ubi-reader before 0.8.5.

    Recommended action: Upgrade to 0.8.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.9PyPIAmendedPublished

    UBI Reader vulnerable to Path Traversal

    CVE-2022-4572 · GHSA-hc37-84v3-8gmq

    Affected
    • PyPI ubi-reader < 0.8.5
    Fixed in
    0.8.5· Vendor fix available
    Issue
    A vulnerability, which was classified as problematic, has been found in UBI Reader up to 0.8.0. Affected by this issue is the function ubireaderextractfiles of the file ubireader/ubifs/output.py of the component UBIFS File Handler. The manipulation leads to path traversal. The attack may be launched remotely. Upgrading to version 0.8.5 can address this issue. The name of the patch is d5d68e6b1b9f7070c29df5f67fc060f579ae9139. It is recommended to upgrade the affected component. VDB-216146 is the identifier assigned to this vulnerability.

    Recommended action: Upgrade to 0.8.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →