Skip to content

← Actionable
Medium, CVSS 6.8amended

Path traversal in ubi-reader

CVE-2023-0591GHSA-vp2x-3mc3-3cj4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ubi-reader 0.8.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2023-0591: 0.39% estimated exploitation activity in the next 30 days; percentile 33.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

ubireaderextractfiles is vulnerable to path traversal when run against specifically crafted UBIFS files, allowing the attacker to overwrite files outside of the extraction directory (provided the process has write access to that file or directory). This is due to the fact that a node name (dentnode.name) is considered trusted and joined to the extraction directory path during processing, then the node content is written to that joined path. By crafting a malicious UBIFS file with node names holding path traversal payloads (e.g. ../../tmp/outside.txt), it's possible to force ubireader to write outside of the extraction directory. This issue affects ubi-reader before 0.8.5.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vp2x-3mc3-3cj4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-vp2x-3mc3-3cj4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-0591

Advisory: Path traversal in ubi-reader
IDs: CVE-2023-0591, GHSA-vp2x-3mc3-3cj4
Record: https://patchnext.com/advisories/cve-2023-0591 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ubi-reader 0.8.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ubi-reader: affected < 0.8.5; fixed in 0.8.5

## Suggested inspection (read-only)
- `python -m pip show ubi-reader`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ubi-reader.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vp2x-3mc3-3cj4 (OSV record GHSA-vp2x-3mc3-3cj4 lists affected ranges: PyPI ubi-reader >=0 <0.8.5 (fixed))
- Verified: https://github.com/advisories/GHSA-vp2x-3mc3-3cj4 (GitHub-reviewed advisory GHSA-vp2x-3mc3-3cj4 lists affected ranges: PyPI ubi-reader >=0 <0.8.5)

Commands are suggestions: review each one before running it.

Loading voting…