Skip to content

← Public intelligence

PyPI package

tkeasygui

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.3PyPIAmendedPublished

    TkEasyGUI Vulnerable to OS Command Injection

    CVE-2025-55037 · GHSA-hfrj-3w3g-jv32

    Affected
    • PyPI tkeasygui < 1.0.22
    Fixed in
    1.0.22· Vendor fix available
    Issue
    Improper neutralization of special elements used in an OS command ('OS Command Injection') issue exists in TkEasyGUI versions prior to v1.0.22. If this vulnerability is exploited, an arbitrary OS command may be executed by a remote unauthenticated attacker if the settings are configured to construct messages from external sources.

    Recommended action: Upgrade to 1.0.22 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.5PyPIAmendedPublished

    TkEasyGUI Affected by Uncontrolled Search Path Element Issue

    CVE-2025-55671 · GHSA-ph2w-cx28-vhrq

    Affected
    • PyPI tkeasygui < 1.0.22
    Fixed in
    1.0.22· Vendor fix available
    Issue
    Uncontrolled search path element issue exists in TkEasyGUI versions prior to v1.0.22. If this vulnerability is exploited, arbitrary code may be executed with the privilege of running the program.

    Recommended action: Upgrade to 1.0.22 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →