Skip to content

← Actionable
Critical, CVSS 9.3amended

TkEasyGUI Vulnerable to OS Command Injection

CVE-2025-55037GHSA-hfrj-3w3g-jv32

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tkeasygui 1.0.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-55037: 2.34% estimated exploitation activity in the next 30 days; percentile 83.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper neutralization of special elements used in an OS command ('OS Command Injection') issue exists in TkEasyGUI versions prior to v1.0.22. If this vulnerability is exploited, an arbitrary OS command may be executed by a remote unauthenticated attacker if the settings are configured to construct messages from external sources.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hfrj-3w3g-jv32

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hfrj-3w3g-jv32

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-55037

Advisory: TkEasyGUI Vulnerable to OS Command Injection
IDs: CVE-2025-55037, GHSA-hfrj-3w3g-jv32
Record: https://patchnext.com/advisories/cve-2025-55037 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tkeasygui 1.0.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tkeasygui: affected < 1.0.22; fixed in 1.0.22

## Suggested inspection (read-only)
- `python -m pip show tkeasygui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tkeasygui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hfrj-3w3g-jv32 (OSV record GHSA-hfrj-3w3g-jv32 lists affected ranges: PyPI tkeasygui >=0 <1.0.22 (fixed))
- Verified: https://github.com/advisories/GHSA-hfrj-3w3g-jv32 (GitHub-reviewed advisory GHSA-hfrj-3w3g-jv32 lists affected ranges: PyPI tkeasygui >=0 <1.0.22)

Commands are suggestions: review each one before running it.

Loading voting…