Skip to content

← Public intelligence

PyPI package

tensorflow-gpu

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

427 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7PyPIAmendedPublished

    Improper Restriction of Operations within the Bounds of a Memory Buffer in Google TensorFlow

    CVE-2018-8825 · GHSA-frxx-2m33-6wcr

    Affected
    • PyPI tensorflow-gpu >= 1.5.0, < 1.7.1
    Fixed in
    1.7.1· Vendor fix available
    Issue
    Google TensorFlow 1.7 and below is affected by: Buffer Overflow. The impact is: execute arbitrary code (local). Users passing a malformed or malicious version of a TFLite graph into TOCO will cause TOCO to crash or cause a buffer overflow, potentially allowing malicious code to be executed.

    Recommended action: Upgrade to 1.7.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)osv.dev (2)github.com (3)Source checked Evidence →
  2. High, CVSS 7.1PyPIAmendedPublished

    Null pointer dereference in TensorFlow leads to exploitation

    CVE-2018-7576 · GHSA-jfq2-rj7f-9gvf

    Affected
    • PyPI tensorflow-gpu >= 1.0.0, < 1.6.0
    Fixed in
    1.6.0· Vendor fix available
    Issue
    Google TensorFlow 1.0.0 through 1.5.1 is affected by: Null Pointer Dereference. The type of exploitation is: context-dependent.

    Recommended action: Upgrade to 1.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)osv.dev (2)github.com (3)Source checked Evidence →