Improper Restriction of Operations within the Bounds of a Memory Buffer in Google TensorFlow
CVE-2018-8825GHSA-frxx-2m33-6wcr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 1.7.1; tensorflow-gpu 1.7.1; tensorflow-cpu 1.7.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tensorflow
- Affected
- >= 1.5.0, < 1.7.1
- Fixed in
- 1.7.1
PyPI tensorflow-gpu
- Affected
- >= 1.5.0, < 1.7.1
- Fixed in
- 1.7.1
PyPI tensorflow-cpu
- Affected
- < 1.7.1
- Fixed in
- 1.7.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-frxx-2m33-6wcr lists affected ranges: PyPI tensorflow >=1.5.0 =1.5.0 <1.7.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2019-226 lists affected ranges: PyPI tensorflow-cpu >=0 <1.7.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-frxx-2m33-6wcr lists affected ranges: PyPI tensorflow >=1.5.0 =1.5.0 <1.7.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2018-8825: 0.74% estimated exploitation activity in the next 30 days; percentile 54.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Google TensorFlow 1.7 and below is affected by: Buffer Overflow. The impact is: execute arbitrary code (local). Users passing a malformed or malicious version of a TFLite graph into TOCO will cause TOCO to crash or cause a buffer overflow, potentially allowing malicious code to be executed.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-frxx-2m33-6wcr
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record PYSEC-2019-226
- Revision 1 · created ·
Published from osv record GHSA-frxx-2m33-6wcr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-8825 Advisory: Improper Restriction of Operations within the Bounds of a Memory Buffer in Google TensorFlow IDs: CVE-2018-8825, GHSA-frxx-2m33-6wcr Record: https://patchnext.com/advisories/cve-2018-8825 (revision 4, source checked 26 Oct 2026, 13:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tensorflow 1.7.1; tensorflow-gpu 1.7.1; tensorflow-cpu 1.7.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tensorflow: affected >= 1.5.0, < 1.7.1; fixed in 1.7.1 - PyPI tensorflow-gpu: affected >= 1.5.0, < 1.7.1; fixed in 1.7.1 - PyPI tensorflow-cpu: affected < 1.7.1; fixed in 1.7.1 ## Suggested inspection (read-only) - `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-frxx-2m33-6wcr (OSV record GHSA-frxx-2m33-6wcr lists affected ranges: PyPI tensorflow >=1.5.0 =1.5.0 <1.7.1 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2019-226 (OSV record PYSEC-2019-226 lists affected ranges: PyPI tensorflow-cpu >=0 <1.7.1 (fixed)) - Verified: https://github.com/advisories/GHSA-frxx-2m33-6wcr (GitHub-reviewed advisory GHSA-frxx-2m33-6wcr lists affected ranges: PyPI tensorflow >=1.5.0 =1.5.0 <1.7.1) Commands are suggestions: review each one before running it.
Loading voting…