Skip to content

← Public intelligence

PyPI package

tablib

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.8PyPIPublished

    tablib: Stored XSS in the HTML export via unescaped dataset title

    CVE-2026-9318 · GHSA-gqgw-jghv-mxwx

    Affected
    • PyPI tablib < 3.10.0
    Fixed in
    3.10.0· Vendor fix available
    Issue
    tablib prior to 3.10.0 contains a stored cross-site scripting vulnerability in the HTML export functionality that allows attackers to execute arbitrary JavaScript by embedding malicious payloads in dataset titles, which are interpolated unsanitized into HTML output via the exportbook method in the html.py format handler. Attackers can rename worksheet sheets in imported files such as XLSX, ODS, XLS, or YAML with script payloads that are assigned to the Dataset title attribute and rendered unescaped inside an HTML h3 tag, leading to session hijacking, unauthorized administrative actions, and sensitive data exposure when the output is rendered in a browser.

    Recommended action: Upgrade to 3.10.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.3PyPIAmendedPublished

    Loaded Databook of Tablib prone to python insertion resulting in command execution

    CVE-2017-2810 · GHSA-gcr6-rf47-jrgf

    Affected
    • PyPI tablib < 0.11.5
    Fixed in
    0.11.5· Vendor fix available
    Issue
    An exploitable vulnerability exists in the Databook loading functionality of Tablib 0.11.4. A yaml loaded Databook can execute arbitrary python commands resulting in command execution. An attacker can insert python into loaded yaml to trigger this vulnerability.

    Recommended action: Upgrade to 0.11.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →